Ubuntu:Feisty pt BR

From

Revision as of 12:27, 8 October 2009 by Krampo (Talk | contribs)
(diff) ← Older revision | Current revision (diff) | Newer revision → (diff)
Jump to: navigation, search

* Em tradução *

Image:Ubuntuguide_logo.png

Contents

Guia não oficial para iniciantes do Ubuntu 7.04 (Feisty Fawn)

O Ubuntu 7.04 (Feisty Fawn) foi lançado a 19 de Abril de 2007. Este guia está em constante evolução. A sua ajuda a melhorar e testar este guia é essencial.

Este guia foi começado por Danilo Gustavo Magrini (Marília, Brasil).

Para editar páginas precisa de se registar -- register

Se tiver alguma dúvida, envie um e-mail para ubuntuguide -at- ubuntuguide.org

MikrobartOrvilsQuashJiyuu0CargoGabemorrBytecopekrampoSimosStubbyeljacoshaiThunderMHasileadammichaelroachBelisarivsCheatorHankTamalKaotikssoniahKutanMehdirichuxShadymanHavarillfr0zen_penguinLouisShadymanshanlot751EtienneRabid9797Mantas Smelevičiusperspectoffphloseadogsmalugo2debugPakosRedBassCyberAngelCogeeldineroycorreAlgimantasBucinskasUficAntidrugueVahidLouis KingRsinghBorut-TCinglallsTownrayANtuMaLaMpete alleboneGreenstarThe TurkRonBCompotatojoMbrasigma80EnlightenedswineKarthikeyanemorrp1Th0rv4ldjspanglerSevoirForainand other friends of our community edit


Versões Anteriores

Se utiliza uma versão mais antiga do Ubuntu (Breezy, Dapper, Edgy), é aconselhável a atualização para o Feisty. Veja aqui como proceder: [Como upgrade from Hoary Hedgehog -> Breezy Badger -> Dapper Drake]

Notas Gerais

  1. Este é o guia não-oficial do Ubuntu 7.04 (Edgy Eft) para iniciados. Não é associado com Ubuntu nem com a Canonical Ltda.
  2. Este guia pode ser discutido no fórum oficial UbuntuGuide.org Forum em ubuntuforums.org. Entre na discussão.
  3. Se vir uma caixa delimitada, significa que tem de executar o comando em questão no modo Terminal (Aplicações - Ferramentas do sistema - Terminal) ou usar o conteúdo da caixa.
  4. Para evitar erros de escrita, copie e cole os comandos para o modo Terminal (Clique botão direito nos comandos ->"Copiar" ou "Colar". Também pode usar Ctrl+C para copiar e Shift+Insert para Colar)
  5. "sudo" significa "superuser do" ( SuperUsuario faz ). "sudo" vai pedir "Password:". Por favor insira a senha do utilizador
  6. Se quiser mais informação sobre algum comando, simplesmente procure nas páginas do manual referente usando o comando “man”. Por exemplo, “man sudo” vai mostrar a página do manual referente ao comando “sudo”.
  7. Se está cansado de escrever "apt-get" todas as vezes, Leia ##Como apt-get the easy way (Synaptic)
  8. "apt-get" e "wget " requerem uma conexão com a Internet para instalar/atualizar/baixar os programas.
  9. Todas as referências a "apt-get" foram substituidas por "aptitude". Pode continuar a usar "apt-get" se assim desejar. Este ponto pode ser discutido em Ubuntu Forums
  10. Para fazer download de um arquivo, clique com o botão direito do mouse -> Selecione "Salvar link como..." -> Verifique se o nome e a extensão do arquivo estão corretos
  11. Se deseja ajudar a traduzir o Ubuntu para a sua língua ou ajudar o Ubuntu de outra maneira, visite https://launchpad.net/
  12. Que o espírito "humanidade para com os outros" esteja sempre contigo....


Se está usando a versão 64-bit substitua qualquer "i386" por "amd64"

Para Começar

Onde ver alguns Screenshots do Ubuntu:

Onde ver screenshots / screencasts do Xubuntu


Onde procurar por novos programas

Onde procurar customizações para o desktop

Existem outros guias *buntu?


Upgrade do Ubuntu Edgy para o Ubuntu Feisty

Como adicionar repositórios extra

  • Leia #Notas Gerais
  • Pode-se adicionar repositórios extras utilizando a aplicação Canais de Software, que pode ser encontrado no menu: Sistema -> Administração -> Canais de Software. Ativar os repositórios que você achar que precisará (main, universe, restricted, multiverse). Provavelmente não precisará do repositório "sources". Este é o método recomendado para adicionar repositórios:


  • Outro caminho para adicionar repositórios extras é fazendo os passos seguintes (faça isto por sua conta e risco):
  • Criar um backup da lista de "sources" dos repositórios.
sudo cp -p /etc/apt/sources.list /etc/apt/sources.list_backup
  • Abrir a lista de "sources" em um editor de texto
Usuários Ubuntu (GNOME):
sudo gedit /etc/apt/sources.list
Usuários Kubuntu (KDE):
sudo kate /etc/apt/sources.list
Outros usuários (se os acima não funcionarem):
sudo nano /etc/apt/sources.list
  • Usar as linhas seguintes como um template para guiar você na edição dos repositórios no arquivo sources.list:
Pode-se tentar susbtituir as linhas atuais do sources.list pelas linhas seguintes
Para tirar melhor proveito de mirrors nacionais adicionar "br." antes de archive.ubuntu.com, onde br = código do Brasil
e.g. deb http://br.archive.ubuntu.com/ubuntu edgy main restricted universe multiverse

Internacional

## Ler http://help.ubuntu.com/community/UpgradeNotes para ver como fazer upgrade
## para novas versões da distribuição.

## Adicionar o sinal de comentário (##) no início de qualquer linha para não ser verificada.   
## Usar a seguinte sources.list por sua conta e risco.  

## Uncomment deb-src if you wish to download the source packages

## If you have a install CD you can add it to the reposity using 'apt-cdrom add'
## which will add a line similar to the following:
#deb cdrom:[Ubuntu 7.04 _Feisty Fawn_ - Beta i386 (20070322.1)]/ feisty main restricted
deb http://us.archive.ubuntu.com/ubuntu/ feisty main restricted
#deb-src http://us.archive.ubuntu.com/ubuntu/ feisty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ feisty-updates main restricted
#deb-src http://us.archive.ubuntu.com/ubuntu/ feisty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://us.archive.ubuntu.com/ubuntu/ feisty universe
#deb-src http://us.archive.ubuntu.com/ubuntu/ feisty universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ feisty multiverse
#deb-src http://us.archive.ubuntu.com/ubuntu/ feisty multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ feisty-backports main restricted universe multiverse
#deb-src http://us.archive.ubuntu.com/ubuntu/ feisty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu feisty-security main restricted
#deb-src http://security.ubuntu.com/ubuntu feisty-security main restricted
deb http://security.ubuntu.com/ubuntu feisty-security universe
#deb-src http://security.ubuntu.com/ubuntu feisty-security universe
deb http://security.ubuntu.com/ubuntu feisty-security multiverse
#deb-src http://security.ubuntu.com/ubuntu feisty-security multiverse

## PLF REPOSITORY (Unsupported.  May contain illegal packages.  Use at own risk.)
## Medibuntu - Ubuntu 7.04 "feisty fawn"
## Please report any bug on https://launchpad.net/products/medibuntu/+bugs
deb http://medibuntu.sos-sts.com/repo/ feisty free non-free
#deb-src http://medibuntu.sos-sts.com/repo/ feisty free non-free

## CANONICAL COMMERCIAL REPOSITORY (Hosted on Canonical servers, not Ubuntu
## servers. RealPlayer10, Opera, DesktopSecure and more to come.) 
deb http://archive.canonical.com/ubuntu feisty-commercial main

Nacional

Brasil Sources.list

## MAIN
deb http://br.archive.ubuntu.com/ubuntu feisty main restricted universe multiverse
deb-src http://br.archive.ubuntu.com/ubuntu feisty main restricted universe multiverse

## MAJOR BUG FIX UPDATES produced after the final release
deb http://br.archive.ubuntu.com/ubuntu feisty-updates main restricted universe multiverse
deb-src http://br.archive.ubuntu.com/ubuntu feisty-updates main restricted universe multiverse

## UBUNTU SECURITY UPDATES
deb http://br.archive.ubuntu.com/ubuntu feisty-security main restricted universe multiverse
#deb-src http://br.archive.ubuntu.com/ubuntu feisty-security main restricted universe multiverse

## BACKPORTS REPOSITORY (Unsupported.  May contain illegal packages.  Use at own risk.)
#deb http://br.archive.ubuntu.com/ubuntu feisty-backports main restricted universe multiverse
#deb-src http://br.archive.ubuntu.com/ubuntu feisty-backports main restricted universe multiverse

## Proposed Repository ( Repositorio com pacotes propostos para o Ubuntu pela comunidade )
## Descomentar se quiser usar
#deb http://br.archive.ubuntu.com/ubuntu feisty-proposed main restricted universe multiverse
#deb-src http://br.archive.ubuntu.com/ubuntu feisty-proposed main restricted universe multiverse

## Internacional
## Medibuntu - Ubuntu 7.04 "feisty fawn"
## Please report any bug on https://launchpad.net/products/medibuntu/+bugs
deb http://medibuntu.sos-sts.com/repo/ feisty free non-free
#deb-src http://medibuntu.sos-sts.com/repo/ feisty free non-free                                          

## Internacional
## CANONICAL COMMERCIAL REPOSITORY (Hosted on Canonical servers, not Ubuntu
## servers. RealPlayer10, Opera and more to come.) 
deb http://archive.canonical.com/ubuntu feisty-commercial main


  • Grave o arquivo editado
  • Adicionar as chaves gpg necessárias; usar o seguinte comando para adicionar a chave gpg do Repositório medibuntu:
wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add -
  • Atualizar lista de pacotes:
sudo aptitude update


  • Modifique o sources.list original somente se tiver a certeza daquilo que está fazendo. Misturar repositórios pode quebrar o seu sistema.

Updates Ubuntu

Básico sobre o Apt, Software e Pacotes

Aqui você pode encontar algumas noções básicas de como utilizar o sistema de gerenciamento de pacotes Apt.

  • Instalar pacotes
sudo aptitude install <nome_pacote>

Exemplo:

sudo aptitude install mpd sbackup
  • Remover pacotes
sudo aptitude remove <nome_pacote>

Exemplo:

sudo aptitude remove mpd sbackup
  • Procurar por pacotes
sudo aptitude search <palavras_chave>

Exemplos:

sudo aptitude search Music MP3
sudo aptitude search "Text Editor"
  • Atualizar a base de dados do Apt (utilizado depois de adicionar/remover repositórios Apt )
sudo aptitude update
  • Atualizar pacotes
sudo aptitude upgrade
  • Atualizar distribuição completa
sudo aptitude dist-upgrade
  • Instalar pacotes Ubuntu (Debian) (.deb)
sudo dpkg -i pacote.deb
  • Remover um pacote Ubuntu (Debian)
sudo dpkg -r pacote
  • Reconfigurar/Reparar pacote instalado
sudo dpkg-reconfigure pacote

Exemplo:

sudo dpkg-reconfigure mpd
  • Usar Arquivos ".tar.gz" (Tar/GZip)

Para extrair:

tar xvzf package.tar.gz

Para criar:

tar cvfz package.tar.gz folder
  • Usar Arquivos ".tar.bz" (Tar/BZip)

Para extrair:

tar xvjf package.tar.bz

Para criar:

tar cvjf package.tar.bz folder
  • Extrair Arquivos ".bz"
bunzip2 file.bz
  • Extrair Arquivos ".gz"
gunzip file.gz
  • Compilar pacotes a partir do source

Confirme se tem instaladas todas as ferramentas de desenvolvimento necessárias (i.e. bibliotecas, compiladores, headers)

sudo aptitude install build-essential
sudo aptitude install linux-headers-`uname -r`

Extrair o pacote (como indicado acima)

tar xvzf package.tar.gz

Iniciar a compilação

cd /caminho/para/arquivo/extraido
./configure
make
make install

Se a compilação for bem sucedida, pode fazer um pacote Ubuntu (Debian) (.deb) para uso futuro:

Instalar ferramentas de pacotes:

sudo aptitude install checkinstall

Recompilar o pacote utilizando o parâmetro "checkinstall":

cd /caminho/para/arquivo/extraido
./configure
make
checkinstall

Salve o arquivo ".deb" para uso futuro. Pode ser instalado usando:

sudo dpkg -i package.deb

Nota: Estas são instruções básicas e genéricas, e podem não funcionar sempre. Alguns pacotes requerem dependências adicionais e outros parâmetros para poderem ser compilados com sucesso.

Como atualizar manualmente o Ubuntu

sudo aptitude update
sudo aptitude upgrade
sudo aptitude dist-upgrade

OU

Use o Gerenciador de atualizações: Sistema -> Administração -> Gestor de atualizações

Métodos Automatizados

Automatix2

sudo dpkg -i automatix2_1.1-3.6-7.04feisty_i386.deb
  • Automatix2 está disponível em Aplicações > Ferramentas de Sistema > Automatix

Aplicações Extra

Java & Non-Media Browser Plug-ins

Como instalar o J2SE Runtime Environment com plugin para Firefox

sudo aptitude install sun-java6-jre sun-java6-plugin
  • Quando perguntar, aceitar com DLJ os termos da licença

Como instalar o Macromedia Flash Plugin para Firefox

Nota: A melhor forma de instalar o plugin do Macromedia flash para o Firefox é visitar Adobe.com: Versão de teste para Adobe Flash Player. Depois irá aparecer um aviso sobre um plugin em falta. Clique nesse aviso e siga os passos. O Firefox irá instalar o plugin automaticamente quando carregar "Instalar agora".

Também pode ser instalado usando o Gerenciador de Pacotes:

sudo aptitude install flashplugin-nonfree
  • Reiniciar Firefox

Nota: Se o som no Plugin não estiver funcionando (Por exemplo no Youtube)

sudo aptitude install alsa-oss
gksudo gedit /etc/firefox/firefoxrc

Trocar a linha:

FIREFOX_DSP=""

Para:

FIREFOX_DSP="aoss"
  • Reiniciar o Firefox. O som agora já deve Funcionar..

Isto não funciona para amd64, uma vez que não existe plugin firefox para 64-bit. A firefox 32-bit é necessário. Ubuntuforums fornece scripts especiais para configurar algumas aplicações 32-bit no amd64.

Se depois de tentar esta solução o som ainda não funcionar, tente isto:

Como configurar o PulseAudio Sound Server

Eu atualmente achei o PulseAudio a melhor solução, o firefox compartilha o som com outros aplicativos.

Como instalar P2P BitTorrent Client (Azureus)

sudo aptitude install azureus
  • Iniciar o programa em: Aplicações -> Internet -> Azureus

Como instalar o cliente de bittorrent (Deluge)

  • Forma recomendada:

Fazer o download dos arquivos de instalação AQUI se a sua máquina for i386 ou AQUI se for amd64 e dê um duplo clique sobre eles, depois do download efetuado.

  • OU

Fazer o download das dependências, obter o último source, compilar os sources e instalar

sudo aptitude install subversion build-essential python-all-dev python-all \
python-support libboost-dev libboost-thread-dev libboost-date-time-dev \
libboost-filesystem-dev libboost-serialization-dev \
libboost-program-options-dev libboost-regex-dev zlib1g-dev && \
svn checkout http://deluge-torrent.org/svn/trunk deluge && \
cd deluge && python setup.py build && sudo python setup.py install
  • Remover os arquivos de instalação
cd .. && rm -Rf deluge/


  • Iniciar o programa em: Aplicações -> Internet -> Deluge BitTorrent Client

Como Instalar o Wine

sudo aptitude install wine
Como usar utorrent sobre o wine

Isto assume que você baixou o utorrent e instalou o wine.

   sudo gedit /usr/bin/utorrent

Cole dentro do arquivo

   #!/bin/sh
   cd ~/YOURPATH/utorrent
   if [ "$1" != "" ]; then
   var="`echo $1 | sed 's/\//\\\/g'`"
   var="Z:${var}"
   wine utorrent.exe "$var"
   else
   wine utorrent.exe
   fi

Troque "SEU CAMINHO" com a localização do uTorrent. Salve e saia e então digite o seguinte para torná-lo executável.

   sudo chmod a+x /usr/bin/utorrent

Como instalar a ferramenta de pesquisa do Corão (zekr)

Zekr é uma ferramenta open source que permite estudar o Corão. Está planejada para ser uma ferramenta open source, multi-plataforma e universal, que proporcione uma base de estudo do Corão. A ideia é criar uma plataforma o mais generalizada possível, de modo a aceitar diferentes recursos Islamicos.

Atualmente o Zekr tem os seguintes pacotes de língua: Inglês, Persa, Francês, Alemão, Árabe, Indonésio, Russo, Holandês, Curdo, Malaio, Turco e Urdu. Adicionalmente, inclui traduções do Corão em Inglês, Persa e Russo.

  • Verifique que o Sun JRE é o ambiente JRE default (o zekr também funciona com a nova versão do gij).
  • Nesta release, os problemas com os alfabetos Árabes é resolvido com a instalação automática da fonte Scheherazade e utilizá-la como a fonte default do programa. Se está fazendo upgrade de uma versão anterior, é só fazer:
mv ~/.zekr ~/zekr-backup
sudo dpkg --purge zekr
  • Fazer download e instalar zekr:
wget http://easynews.dl.sourceforge.net/sourceforge/zekr/zekr_0.5.0-1_i386.deb
sudo dpkg -i zekr_0.5.0-1_i386.deb

Jogos

Emulador do Super Nintendo (ZSNES)

wget -c http://www.dfreer.org/~dfreer/zsnes/zsnes_latest_i386.deb
sudo dpkg -i zsnes_latest_i386.deb
  • Aplicações > Jogos > zsnes
Para AMD64
wget -c http://www.dfreer.org/~dfreer/zsnes/zsnes_latest_amd64.deb
sudo dpkg -i zsnes_latest_amd64.deb
  • Aplicações > Jogos > zsnes

Emulador do Playstation 1 (pSX)

Para suporte ou questões veja http://ubuntuforums.org/showthread.php?t=394097

wget -c http://www.dfreer.org/~dfreer/pSX/pSX_latest_i386.deb
sudo dpkg -i pSX_latest_i386.deb
  • Aplicações > Jogos > pSX
Para AMD64

Para suporte ou questões veja http://ubuntuforums.org/showthread.php?t=394097

sudo aptitude install ia32-libs ia32-libs-sdl ia32-libs-gtk
wget -c http://www.dfreer.org/~dfreer/pSX/ia32-libs-gtkglext1_latest_amd64.deb
wget -c http://www.dfreer.org/~dfreer/pSX/pSX_latest_amd64.deb
sudo dpkg -i ia32-libs-gtkglext1_latest_amd64.deb
sudo dpkg -i pSX_latest_amd64.deb
  • Aplicações > Jogos > pSX

Outors ambientes de trabalho

Como instalar KDE

sudo aptitude install kubuntu-desktop
Nota: Esta instalação irá precisar de ~400MB de espaço no disco
  • Sistema -> Sair -> Log Out
  • Para iniciar a sessão no KDE, clique em Sessões e escolha KDE

Como instalar XFCE

sudo aptitude install xubuntu-desktop
  • Sistema -> Sair -> Log Out
  • Para iniciar a sessão no XFCE, clique em Sessões e escolha XFCE

Como instalar FluxBox

Aqui estão alguns Screenshots. Fluxbox é um conhecido Gerenciador de Janelas muito Leve.

sudo aptitude install fluxbox
Selecionar o Fluxbox quando iniciada a sessão pelo GDM
echo "exec startfluxbox" > ~/.xinitrc
Ativar um belo som de login
sudo aptitude install sox
gedit ~/.fluxbox/startup
  • Procure esta linha:
exec /usr/local/bin/fluxbox
  • Adicione a linha seguinte, acima da linha mencionada
play /usr/share/sounds/login.wav > /dev/null 2>&1 &
  • Ouça o som ao iniciar a sessão.

Como Montar Partições Windows

Como Montar Partições NTFS

Guia Passo-a-Passo de Como Montar Partições Windows no Feisty

Doce visão

Como instalar o Beryl (ATI)

"Todos os créditos são para os usuários do fórum do link de referência acima. Isto foi adicionado neste wiki "All credit is due to the forum user in the reference link above. Isto foi adicionado à este wiki de modo que outros usuários (esperançosamente) não tenham que procurar por uma solução. Isto foi testado em uma versão i386 do Feisty Fawn. Someone, por favor modifique se a versão AMD64 também é compatível".

  • Abra um terminal:
Aplicações > Acessórios > Terminal
  • Verifique se seu sistema está atualizado
sudo apt-get update
sudo apt-get upgrade
  • Instale o Xgl (Isto é o principal problema com placas ATI. Os drivers fglrx não suportarão o Compiz que já vem instalado no Ubuntu e nós queremos que o Xgl rode nossa versão do Beryl com placas ATI. ):
sudo apt-get install xserver-xgl
  • Escreva um script para que o Xgl possa inicializar:
sudo gedit /usr/local/bin/startxgl.sh
  • Entre e salve estas informações no script
#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
exec dbus-launch --exit-with-session gnome-session
  • Se você tem problemas com seu desligar(shutdown) e reinicializar(restart), use isto:
#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec dbus-launch --exit-with-session gnome-session
  • Torne seu script executável:
sudo chmod a+x /usr/local/bin/startxgl.sh
  • Agora, nós precisamos colocar uma opção de login Xgl na nossa tela do GDM:
sudo gedit /usr/share/xsessions/xgl.desktop
  • Entre e salve essas informações no script
[Desktop Entry]
Encoding=UTF-8
Name=GNOME with XGL
Comment=
Exec=/usr/local/bin/startxgl.sh
Icon=
Type=Application
  • Também torne-o executável:
sudo chmod a+x /usr/share/xsessions/xgl.desktop
  • Desative o repositório universe (estes fornecem o software Beryl que é incompatível com o driver fglrx).
Vá para Sistema > Administração > Fontes de Programas
Desmarque Community-maintained Open Source software (universe)
Clique em Fechar

Volte para seu terminal:

  • Adicione a chave correta para o repositório:
sudo wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- | sudo apt-key add -
  • Adicione o repositório correto no topo de seu apt source list:
sudo gedit /etc/apt/sources.list
Entre com: deb http://ubuntu.beryl-project.org/ feisty main
Salve e feche o gedit 
  • Atualize seu apt sources:
sudo apt-get update
  • Instale a aplicação Beryl correta:
sudo apt-get install beryl emerald-themes

O Apt deveria recuperar todas as dependências tais como plug-ins e bibliotecas

  • Instale seus drivers ATI (se necessário):
Vá em Sistema > Administração > Gerenciador de Drivers Restritos
Marque a caixa de Habilitar para sua placa ATI
Você precisará reiniciar para habilitar sua placa. (Em muitos casos um CTRL+ALT+BACKSPACE é suficiente)

  • Depois de reiniciar e escolha Xgl da sua lista de sessões na tela de login, teste o Beryl. No terminal:
beryl-manager
emerald --replace

Você deveria ver o diamante do Beryl próximo do relógio, e deveria tentar mover uma janela. Você pode precisar clicar com o botão direito no diamante, selecionar "Beryl" na janela flutuante "Selecionar Gerenciador de Janela" e selecionar "Decoração padrão Beryl (Emerald)" do "Selecionar Gerenciador de Janela". Você pode também precisar clicar Reiniciar para cada um abaixo do mesmo menu.

  • Se você está usando ATI com XGL, você receberá um erro que o beryl-xgl está faltando. A solução não é elegante, mas funciona:
Baixe beryl-core deb de http://ubuntu.beryl-project.org/pool/feisty/main/0.2.0/beryl-core_0.2.0~0beryl1_i386.deb
Descompacte beryl-xgl do arquivo para por exemplo: ~/Desktop
Do terminal execute: sudo cp ~/Desktop/beryl-xgl /usr/bin/beryl-xgl

  • Se todo isso funcionar bem, adicione o Beryl e os temas Esmeralda para seus programas de inicialização:
Vá em Sistema > Preferências > Sessões
Clique no botão Novo
Digite "Beryl" (sem aspas) para a caixa de textos Nome
Digite "beryl-manager" (sem aspas) para a caixa de texto Comando:
Clique no botão OK (Aceitar)

Clique no botão Novo
Digite "Temas Esmeralda" (sem aspas) para a caixa de textos Nome
Digite "emerald --replace" (sem aspas) para a caixa de texto Comando:
Clique no botão OK (Aceitar)

Parabéns! Você tem o Beryl funcionando agora. Você pode agora reativar os repositórios universe, mas tenha certeza que você não vai atualizar nada relacionado ao Beryl. Os aplicativos Beryl do repositório universe logo trabalharão com placas ATI sem Xgl.

Como instalar o Compiz (Nvidia)

Como instalar o Beryl (Nvidia)


  • Atualize todos os pacotes
sudo aptitude update
sudo aptitude dist-upgrade
  • Faça um backup do xorg.conf
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
gksudo gedit /etc/X11/xorg.conf
  • Instale os Drivers da Nvidia para Placas Gráficas*
    • Sistema > Administração > Gerenciador de Drivers Restritos

Habilite os Drivers Nvidia


Ctrl+Alt+Backspace para fazer os drivers da Nvidia serem ativados

  • Instale o Beryl
sudo aptitude install beryl emerald-themes beryl-manager
  • Inicie o Beryl
beryl-manager
  • Inicie o Emerald (se ele ainda não foi inicializado)
emerald --replace
  • Faça o Beryl e o Emerald carregarem no login
    • Sistema > Preferências > Sessões
    • Inicialização de Programas > Adicionar
beryl-manager

and

emerald --replace
    • Se, no reinicio, os menus do programa não estiverem sendo exibidos corretamente (você não pode vê-los quando tentar selecionar porque eles são mostrados atrás da janela) então clique no ícone 'Gerenciador do Beryl' no painel (o ícone vermelho) e selecione 'Recarregar Gerenciador de Janelas'. O problema deveria ser resolvido a próxima vez que reiniciar.

O que fazer se os players de vídeo travarem enquanto estiver usando o Beryl

veja bug 96226 Atualmente você precisará mudar o driver de vídeo de xv para x11 no ~/.mplayer/config ang gstreamer-properties

Como melhorar os sub-pixel da fonte renderizada pelo Feisty

Isto irá melhorar incrívelmente a aparência da fonte em relação a instalação padrão. As bibliotecas de correção estão sendo construidas no Freetype 2.3.x (não incluída atualmente no feisty) e inclue as correções de renderização da sub-pixel de David Turner.

  • Para i386 adicione o seguinte para seu /etc/apt/sources.list
deb http://www.telemail.fi/mlind/ubuntu feisty fonts
deb-src http://www.telemail.fi/mlind/ubuntu feisty fonts
  • Para AMD64/EMT adicione o seguinte para /etc/apt/sources.list
deb http://raof.dyndns.org/falcon feisty experimental
deb-src http://raof.dyndns.org/falcon feisty experimental
  • Pacotes para você atualizar são libfreetype6, libcairo2 and libxft2
sudo aptitude update
sudo aptitude install libfreetype6 libcairo2 libxft2
  • Depois da instalação, você pode querer reconfigurar as fontes. As seguintes configurações funcionam bem:: Native, Automatic, No bitmapped fonts.
sudo dpkg-reconfigure fontconfig-config
sudo dpkg-reconfigure fontconfig
  • Se você obtiver erros de chaves gpg
gpg --keyserver subkeys.pgp.net --recv-keys 937215FF
gpg --export --armor 937215FF | sudo apt-key add -
  • Chave GPG para o respositório de pacotes AMD64/EMT
wget http://ubuntu.moshen.de/2F306651.gpg -O- | sudo apt-key add -
  • Neste ponto você pode reiniciar seu computador ou reiniciar o X (Ctrl + Alt + Backspace) para ver as mudanças.


Nota: Se você mais tarde decidir voltar os pacotes do Ubuntu, você deve realizar um downgrade (desatualizar) todos os três pacotes instalados.

source: http://ubuntuforums.org/showthread.php?t=343670

Como configurar GLSlideshow

  • GLSlideshow é um protetor de tela que mostra suas imagens em um show de imagens. To enable it:
Sistem > Preferências > Protetor de Tela
Escolha GLSlideshow
  • Feisty não oferece uma forma de editar o diretório de imagens. Para mudá-la, crie um arquivo .xscreensaver no seu diretório home:
gedit .xscreensaver
  • Adicione esta linha:
imageDirectory:	/caminho/para/imagem
  • Salve e teste o protetor de telas travando sua tela. Você irá ver suas imagens, mas ele ainda repetirá as mesmas uma a uma. Para corrigir isso, mude seu arquivo de configuração glslideshow.desktop:
gksudo gedit /usr/share/applications/screensavers/glslideshow.desktop


  • procure a seguinte entrada:
Exec=glslideshow -root
  • Modifique esta linha
    • Veja na página man para glslideshow o que esta opção significa, e veja também outras opções:
Exec=glslideshow -root -duration 10 -pan 10 -fade 3
  • Grave e tente executar o protetor de tela novamente. Você deveria ver todas suas imagens em ordem aleatória.

source: http://rclermont.blogspot.com/2007/02/modifying-glslideshow-settings-in_28.html

ESTE DOCUMENTO ESTÁ EM CONSTRUÇÃO.

Personal tools
Sponsor