Ubuntu:Edgy Tr/AddOnApplications

From

Jump to: navigation, search

Contents

Add-On Applications

How to install EasyUbuntu

  • Read #General Notes
  • Easy Ubuntu is a small straight-forward utility that allows novice users to easily install a wide variety of content for Ubuntu such as media codecs, fonts, Macromedia Flash and Sun Java.

Open a terminal from Menu -> Accessories -> Terminal and run the following commands

wget http://easyubuntu.freecontrib.org/files/easyubuntu-3.023.tar.gz
tar -zxf easyubuntu-3.023.tar.gz
cd easyubuntu
cp packagelist-dapper.pot packagelist-edgy.pot
cp packagelist-dapper.xml packagelist-edgy.xml
sudo python easyubuntu.in
  • From the Easy Ubuntu window, check the appropriate boxes to download and install content to Ubuntu.
  • Note: Users of the previous EasyUbuntu 3.0 version may experience issues with installing Flash and Java.
  • If you would like automatic update, then follow these instructions:

depending on which version of Ubuntu you're using:

On Ubuntu:

sudo gedit /etc/apt/sources.list

On Kubuntu:

sudo kate /etc/apt/sources.list

On Xubuntu:

gksudo mousepad /etc/apt/sources.list

In your text editor which will open, add to the bottom of your /etc/apt/sources.list file:

deb http://easyubuntu.cafuego.net main easyubuntu

From now on, EasyUbuntu should be automatically updated.

How To Uninstall EasyUbuntu
sudo apt-get remove easyubuntu
  • Delete the easyubuntu directory

How to install Automatix2 on Ubuntu, Kubuntu, and Xubuntu

  • Read #General Notes
  • Automatix2 is Automatix written in python with a more user friendly interface and better overall design for automating the installation of the most commonly requested applications in Ubuntu/Kubuntu/Xubuntu linux.
  • Note: Before installing, please note that certain codecs it provides may be prohibited in certain countries. You are responsible for ensuring those laws are not broken.
sudo gedit /etc/apt/sources.list 
  • Add the following lines at the end of file
## Automatix repo
deb http://www.getautomatix.com/apt edgy main
  • NOTE: Kubuntu/Xubuntu users will need to uncomment (remove the # before the word "deb") all the additional sources as well as add the automatix repository.
  • Acquire GPG key
wget http://www.getautomatix.com/apt/key.gpg.asc
gpg --import key.gpg.asc
gpg --export --armor 521A9C7C | sudo apt-key add -

  • Update APT
sudo apt-get update
  • Run the following commands to install Automatix2
sudo apt-get install automatix2

  • Automatix2 can be started from the the Menu
Menu -> System -> Automatix
  • Automatix2 can be run from terminal by typing the folowing
automatix2

Another script to install additional programs

wget http://www.iki.fi/kuparine/comp/ubuntu/install.sh
sh install.sh

More information about this installation method can be found at http://www.iki.fi/kuparine/comp/ubuntu/install.html

How to install J2SE Runtime Environment (JRE) with Plug-in for Mozilla Firefox

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install sun-java5-jre sun-java5-plugin
  • When asked, agree with DLJ license terms.

How to install JRE v5.0 Update 9

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

Choose "Java Runtime Environment (JRE) 5.0 Update 9" and click on "Download"
Accept License Agreement 
Download the "Linux self-extracting file"
  • Install the required tool :
sudo apt-get install java-package
  • Create the Ubuntu package :
fakeroot make-jpkg jre-1_5_0_09-linux-i586.bin
  • Install the resulting package :
sudo dpkg -i sun-j2re1.5_1.5.0+update09_i386.deb


  • Restart Mozilla Firefox
  • If you get an error, try changing the 09's in the filenames to the appropriate version number.

How to install Java Development Kit (JDK) v5.0

sudo apt-get install sun-java5-jdk
  • Accept the licence agreement that appears.
  • Set Sun's JVM as default Java version:
sudo update-java-alternatives -s java-1.5.0-sun
  • Edit /etc/jvm and move /usr/lib/jvm/java-1.5.0-sun to the top of JVMs offered:
gksudo gedit /etc/jvm

How to install Flash Player (Macromedia Flash) Plug-in for Mozilla Firefox

sudo apt-get install flashplugin-nonfree
sudo update-flashplugin

Note: if you get an error message that the package is not found, try the Gnash (GNU Flash substitute)

sudo apt-get install libflash-mozplugin
  • Restart Mozilla Firefox


Note: if firefox crashes when visiting a website with flash content, do the following:

sudo gedit /usr/bin/firefox

and add the following line as last but one line of the file:

export XLIB_SKIP_ARGB_VISUALS=1

Now firefox shouldn't crash anymore. (Launchpad bug report: [1])

  • Restart Mozilla Firefox


Note: if sound doesn't work in Flash Player (for example on YouTube):

sudo apt-get install alsa-oss
gksudo gedit /etc/firefox/firefoxrc

Change:

FIREFOX_DSP=""

To:

FIREFOX_DSP="aoss"
  • Restart Mozilla Firefox. Now sound should work in Flash Player.

How to update to Flash Player 9 Beta 2 (Macromedia Flash) Plug-in for Mozilla Firefox

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

wget http://download.macromedia.com/pub/labs/flashplayer9_update/FP9_plugin_beta_112006.tar.gz
tar xvzf FP9_plugin_beta_112006.tar.gz
sudo cp flash-player-plugin-9.0.21.78/libflashplayer.so /usr/lib/flashplugin-nonfree/ 
  • Restart Mozilla Firefox

How to install PDF Reader (Adobe Reader) with Plug-in for Mozilla Firefox

sudo apt-get install acroread mozilla-acroread acroread-plugins
  • Applications -> Office -> Adobe Reader
  • Restart Mozilla Firefox

Note: Adobe Reader 7.0 will not run if SCIM is running. You are running SCIM if you have installed another language to Ubuntu via System -> Administration -> Language Support. To circumvent, do the following

gksudo gedit /usr/bin/acroread

Change:

#!/bin/sh
#

to:

#!/bin/sh
#
GTK_IM_MODULE=xim

Save the file. Now Adobe Reader 7.0 should work.

See also:

How to install Download Manager (Downloader for X)

sudo apt-get install d4x
  • Applications -> Internet -> Downloader for X
How to uninstall Download Manager (Downloader for X)
sudo apt-get remove d4x

How to install a password manager (Revelation)

sudo apt-get install revelation
  • Applications -> Accessories -> Revelation Password Manager
How to uninstall Revelation
sudo apt-get remove revelation

How to Automatically cycle Flickr images as your Ubuntu desktop wallpaper

Check here for Ubuntu Wallpapers You want to make your ubuntu desktop more Colourful and Beautiful this is for you

How to install FTP Client (gFTP)

sudo apt-get install gftp
  • Applications -> Internet -> gFTP
How to uninstall gFTP
sudo apt-get remove gftp

How to install IRC Client (XChat)

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install xchat xchat-systray 
  • Applications -> Internet -> XChat IRC
How to uninstall XChat
sudo apt-get remove xchat xchat-systray

How to install File share utility (LinuxDC++)

wget -c http://easylinux.info/uploads/linuxdcpp.tar.gz
sudo tar zxvf linuxdcpp.tar.gz -C /opt
gksudo gedit /usr/share/applications/linuxdcpp.desktop
  • Insert the following lines into the new file
[Desktop Entry]
Encoding=UTF-8
Name=LinuxDC++
Exec=linuxdcpp
Terminal=false
Type=Application
StartupNotify=true
Icon=/opt/linuxdcpp/pixmaps/linuxdcpp.png
Categories=Application;Network;
  • Save the edited file
  • Applications -> Internet -> LinuxDC++
  • If you whant to build the latest version from CVS use this guide

How to install P2P BitTorrent Client (Azureus)

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install azureus
  • Applications -> Internet -> Azureus
(Alternative Method)

The above method installs a version of Azureus compiled with gcj, the free alternative to Sun's Java.

wget http://kent.dl.sourceforge.net/sourceforge/azureus/Azureus_2.5.0.0_linux.tar.bz2
sudo tar jxvf Azureus_2.5.0.0_linux.tar.bz2 -C /opt/
sudo gedit /usr/share/applications/azureus.desktop
  • Add the following to the new file
[Desktop Entry] 
Name=Azureus
Comment=Java BitTorrent Client
Exec=/opt/azureus/azureus
Icon=/opt/azureus/Azureus.png
Terminal=false
Type=Application
Categories=Application;Network;
  • Save the edited file
  • Applications -> Internet -> Azureus
How to uninstall Azureus
sudo apt-get remove azureus

How to install P2P BitTorrent Client (Bittornado)

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install bittornado bittornado-gui
  • Applications -> Internet -> Bittornado Client
How to uninstall Bittornado
sudo apt-get remove bittornado bittornado-gui

How to install P2P eMule Client (aMule)

Note: Program included in Automatix2 and Easy Ubuntu. I you have already used one of them, this program may have been installed

sudo apt-get install amule
  • Applications -> Internet -> aMule
How to uninstall P2P eMule Client (aMule)
sudo apt-get remove amule

How to install P2P Gnutella Client (FrostWire)

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

wget -c http://www.users.on.net/~stubby/FrostWire-4.10.9-2.i586.deb
sudo dpkg -i FrostWire-4.10.9-2.i586.deb
  • Applications -> Internet -> FrostWire

How to install Messenger (Skype)

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

  • With Edgy the Skype is not included in the Ubuntu repositories anymore.
sudo apt-get install libqt3-mt
wget http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype_debian-*.deb
(Alternative Method - Official Skype Repository)
sudo gedit /etc/apt/sources.list
  • Add the following lines to the end of file
## Official Skype Repository
deb http://download.skype.com/linux/repos/debian/ stable non-free
sudo apt-get update
sudo apt-get install skype
  • To run Applications > Internet > Skype

How to install WinPopup (LinPopUp)

sudo apt-get install linpopup
gksudo gedit /usr/share/applications/linpopup.desktop
  • Insert the following lines into the new file
[Desktop Entry]
Name=LinPopUp
Comment=LinPopUp
Exec=linpopup
Icon=/usr/share/pixmaps/linpopup.xpm
Terminal=false
Type=Application
Categories=Application;Utility;
  • Save the edited file
  • Applications -> Accessories -> LinPopUp

How to install Multimedia Codecs

sudo apt-get install gstreamer0.10-ffmpeg gstreamer0.10-gl gstreamer0.10-plugins-base \
gstreamer0.10-plugins-good gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse \
gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse libxine-extracodecs w32codecs 

Stubby All known codecs work except for wmv,

Radiobuzzer WMV9 codecs don't work especially for amd64 users. Advanced users should follow this patch

How to install DVD playback capability

ironss: gstreamer dvd plugin is available as part of plugins-bad (or ugly?) and does not work reliably. However, Totem works with the xine backend to play back DVDs. This will keep you going until gstreamer gets dvd playback. Note that you do not have to install xine-ui or mplayer as suggested in

sudo apt-get install libdvdread3 
sudo /usr/share/doc/libdvdread3/install-css.sh
sudo apt-get install totem-xine

Stubby: gstreamer dvd plugin not ported to dapper yet. following instructions will not work properly

sudo apt-get install libdvdcss2

How to install MIDI sound server (Timidity++)

  • Read #General Notes
  • Read #How to add extra repositories
  • Timidity allows for the playback of MIDI by those who do not have MIDI hardware or MIDI processing built into their sound card (most users) via a software synthesizer.
  • First install Timidity
sudo apt-get install timidity
  • Set up Timidity to start on boot
sudo gedit /etc/default/timidity
  • Uncomment the following line (remove the "#" sign)
#TIM_ALSASEQ=true
  • Set the required modules to load as well
sudo gedit /etc/modules
  • Add the following modules to the end of the file
snd-seq-device
snd-seq-midi
snd-seq-oss
snd-seq-midi-event
snd-seq
  • Restart your computer


How to install Multimedia Player (xine-ui)

sudo apt-get install xine-ui libxine-extracodecs
  • Applications -> Sound & Video -> xine

How to install Multimedia Player (VLC) with plug-in for Mozilla Firefox

sudo apt-get install vlc vlc-plugin-* mozilla-plugin-vlc
  • In order to stream video via vlc, you also need to install the following packages.
apt-get install avahi-daemon
apt-get install avahi-utils
Applications -> Sound and Video -> VLC Media Player

How to install Multimedia Player (Mplayer) with plug-in for Mozilla Firefox

sudo apt-get install mozilla-mplayer
Applications -> Sound and Video -> MPlayer Movie Player

How to install Multimedia Player (Totem) with plug-in for Mozilla Firefox

sudo apt-get install totem-gstreamer-firefox-plugin
  • Restart Mozilla Firefox
How to uninstall Totem with plug-in for Mozilla Firefox
sudo apt-get remove totem-gstreamer-firefox-plugin

How to install Multimedia Player (XMMS)

sudo apt-get install xmms xmms-skins
wget -c http://easylinux.info/uploads/xmms-wma_1.0.4-2_i386.deb
sudo dpkg -i xmms-wma_1.0.4-2_i386.deb
  • Applications -> Sound & Video -> XMMS

How to install Multimedia Player (Songbird)

First download this shell script from Psychocats.net Open up the terminal and type these commands in one at a time

cd Desktop
chmod +x installsongbird.sh
./installsongbird.sh
  • Applications -> Sound & Video -> Songbird

To remove if you want use this shell script and use the same instructions that you used to install songbird but substitute install with remove.

How to install Multimedia Player (amaroK)

sudo apt-get install amarok
  • Applications -> Sound & Video -> amaroK
How to uninstall amaroK
sudo apt-get remove amarok

How to install Multimedia Player (RealPlayer 10)

sudo apt-get install realplay
Note: 'realplay' installs RealPlayer 10 from PLF repository, which you should be enabled if you followed this guide. 'realplayer' installs RealPlayer 8 from multiverse.
  • Applications -> Sound & Video -> RealPlayer 10
  • It will also install all the necessary plugins automagically for it to view embedded real videos in Firefox
  • To avoid issues of flickering or screen going blank when switching windows, goto
  • RealPlayer 10 -> Tools -> Preferences -> Hardware -> Uncheck XVideo

Alternative Source

Then add execute permissions to the installer and execute it.

chmod +x RealPlayer10GOLD.bin
sudo ./RealPlayer10GOLD.bin

How to install Stream Directory Browser (streamtuner)

sudo apt-get install streamtuner
sudo apt-get install streamripper
  • Applications -> Sound & Video -> streamtuner
How to uninstall Stream Directory Browser (streamtuner)
sudo apt-get remove streamtuner streamripper

How to install Music Organizer (Cowbell)

sudo apt-get install cowbell
  • Applications -> Sound & Video -> Cowbell Music Organizer
How to uninstall Cowbell
sudo apt-get remove cowbell

How to install ID3 Tag Editor (EasyTAG)

sudo apt-get install easytag
  • Applications -> Sound & Video -> EasyTAG
How to uninstall ID3 Tag Editor (EasyTAG)
sudo apt-get remove easytag

How to install Video Editor (Kino)

sudo apt-get install kino
sudo apt-get install kinoplus
sudo apt-get install kino-timfx
sudo apt-get install kino-dvtitler
  • Applications -> Sound & Video -> Kino Video Editor
How to uninstall Video Editor (Kino)
sudo apt-get remove kino kinoplus kino-timfx kino-dvtitler

How to install Audio Editor (Audacity)

sudo apt-get install audacity
  • Applications -> Sound & Video -> Audacity
How to uninstall Audacity
sudo apt-get remove audacity

How to install Music Composition Program (NoteEdit)

sudo apt-get install noteedit lilypond
sudo gedit /usr/share/applications/noteedit.desktop
  • Insert the following lines into the new file
[Desktop Entry]
Name=NoteEdit
Comment=A free music score editor
Exec=noteedit
Icon=/usr/share/app-install/icons/noteedit.xpm
Terminal=false
Type=Application
Categories=Application;AudioVideo;
  • Save the file
  • Applications -> Sound & Video -> NoteEdit

How to install Music Manager and Player (Banshee)

sudo apt-get install banshee
How to uninstall Banshee
sudo apt-get remove banshee

How to install DVD Ripper (dvd::rip)

sudo apt-get install dvdrip vcdimager cdrdao subtitleripper
sudo ln -fs /usr/bin/rar /usr/bin/rar-2.80
gksudo gedit /usr/share/applications/dvdrip.desktop
  • Insert the following lines into the new file
[Desktop Entry]
Name=dvd::rip 
Comment=dvd::rip
Exec=dvdrip
Icon=/usr/share/perl5/Video/DVDRip/icon.xpm
Terminal=false
Type=Application
Categories=Application;AudioVideo;
  • Save the edited file
  • Applications -> Sound & Video -> dvd::rip

How to install DVD Ripper (AcidRip)

sudo apt-get install acidrip


Note: AcidRip will not recognize dvd if dma is turned on. If so undo the process #How to speed up CD/DVD-ROM.

How to install CD Ripper (Goobox)

sudo apt-get install goobox
sudo rm -f /usr/share/applications/goobox.desktop
gksudo gedit /usr/share/applications/goobox.desktop
  • Insert the following lines into the new file
[Desktop Entry]
Name=CD Player & Ripper
Comment=Play and extract CDs
Exec=goobox
Icon=goobox.png
Terminal=false
Type=Application
Categories=Application;AudioVideo;
  • Save the edited file
  • Applications -> Sound & Video -> CD Player & Ripper

How to install Image Viewer (digiKam)

sudo apt-get install digikam digikamimageplugins kipi-plugins
  • Applications -> Graphics -> digikam

How to install Picasa image organizer

gksudo gedit /etc/apt/sources.list
  • Add the following lines at the end of file
# Google Picasa for Linux repository
deb http://dl.google.com/linux/deb/ stable non-free
  • Save the edited file
sudo apt-get update
sudo apt-get install picasa
  • Applications -> Graphics -> Picasa

How to install Internet TV (DemocracyTV beta)

  • If your system has a 32bit processor (i386) open a Terminal and type
wget http://ftp.osuosl.org/pub/pculture.org/democracy/linux/ubuntu/democracyplayer-data_0.9.0.2-1ubuntupcf_all.deb
wget http://ftp.osuosl.org/pub/pculture.org/democracy/linux/ubuntu/democracyplayer_0.9.0.2-1ubuntupcf_i386.deb
sudo apt-get upgrade
sudo dpkg -i democracyplayer-data_0.9.0.2-1ubuntupcf_all.deb
sudo apt-get install mozilla-browser mozilla-psm mozilla-dev
sudo dpkg -i democracyplayer_0.9.0.2-1ubuntupcf_i386.deb


  • if your system has a 64bit processor (amd64)
wget http://ftp.osuosl.org/pub/pculture.org/democracy/linux/ubuntu/democracyplayer-data_0.9.0.2-1ubuntupcf_all.deb
wget http://ftp.osuosl.org/pub/pculture.org/democracy/linux/ubuntu/democracyplayer_0.9.0.2-1ubuntupcf_amd64.deb
sudo apt-get upgrade
sudo dpkg -i democracyplayer-data_0.9.0.2-1ubuntupcf_all.deb
sudo apt-get install mozilla-browser mozilla-psm mozilla-dev
sudo dpkg -i democracyplayer_0.9.0.2-1ubuntupcf_amd64.deb

  • in both cases you might also need to install dependencies of the player package if dpkg returns a dependency error.
sudo apt-get -f install
  • to get support for more formats you have to install libxine-extracodecs (check Restricted Formats for more info)
sudo apt-get install libxine-extracodecs

or use an alternate procedure: double click (or right click and select "Open with gdebi") on the deb files so they are opened with gdebi, first democracyplayer-data_0.9.0.2-1ubuntupcf_all.deb and after that democracyplayer_0.9.0.2-1ubuntupcf_i386.deb (if you have a 32bit processor) or democracyplayer_0.9.0.2-1ubuntupcf_amd64.deb (if you have a 64bit processor)

  • Applications -> Sound & Video -> Democracy TV

How to install Vector Graphics Editor (Inkscape)

sudo apt-get install inkscape


Second installation method:

1. Download the official Inkscape Linux installer.
2. Choose a mirror and save it to your Desktop.
3. Right-click it, enable "Properties --> Permissions --> Owner:Execute" and close the dialogue box. (One-time procedure)
4. Double-click it and follow the instructions.
5. Install the support code system-wide, if you have the root password. (One-time procedure)

NOTE: You can and should install the program as a User, rather than Root. This is easily accomplished with the second method.

How to install Opera web browser

sudo apt-get install libqt3-mt
wget http://ftp.wayne.edu/opera/linux/902/final/en/i386/shared/opera_9.02-20060919.6-shared-qt_en_i386.deb
sudo dpkg -i opera_9.02-20060919.6-shared-qt_en_i386.deb
  • Applications -> Internet -> Opera
  • To get java working go to Tools->Preferences->Advanced->Content-> Check "Enable Java". Click the "Enable Java..." button enter "/usr/lib/jvm/java-1.5.0-sun/jre/lib/i386" (for sun java) in the new dialog and then click the "Validate Java Path" button.

How to install Email Client (Mozilla Thunderbird)

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install mozilla-thunderbird
  • Applications -> Internet -> Thunderbird Mail Client

How to install Newsreader (Pan)

sudo apt-get install pan
  • Applications -> Internet -> Pan Newsreader

How to install RSS/RDF/Atom Newsreader (RSSOwl)

wget -c http://easylinux.info/uploads/rssowl_linux_1_1_3_bin.tar.gz
sudo tar zxvf rssowl_linux_1_1_3_bin.tar.gz -C /opt/
sudo chown -R root:root /opt/rssowl_linux_1_1_3_bin/
gksudo gedit /usr/bin/runRSSOwl.sh
  • Insert the following lines into the new file
export MOZILLA_FIVE_HOME=/usr/lib/mozilla-firefox
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:${MOZILLA_FIVE_HOME}:${LD_LIBRARY_PATH}
cd /opt/rssowl_linux_1_1_3_bin/
./run.sh
  • Save the edited file
sudo chmod +x /usr/bin/runRSSOwl.sh
gksudo gedit /usr/share/applications/RSSOwl.desktop
  • Insert the following lines into the new file
[Desktop Entry]
Name=RSSOwl
Comment=RSSOwl
Exec=runRSSOwl.sh
Icon=/opt/rssowl_linux_1_1_3_bin/rssowl.xpm
Terminal=false
Type=Application
Categories=Application;Network;
  • Save the edited file
  • Applications -> Internet -> RSSOwl

How to install WYSIWYG Web Authoring System (Nvu)

sudo apt-get install nvu
  • Save the edited file
  • Applications -> Programming -> Nvu

How to install Web Authoring System (BlueFish)

sudo apt-get install bluefish

  • Applications -> Programming -> Bluefish Editor

How to install Web Development Environment (quanta plus)

sudo apt-get install quanta
  • Applications -> Programming -> Quanta Plus

How to install Project Management Application (Planner)

sudo apt-get install planner
  • Applications -> Office -> Project Management

How to install jedit

wget -c http://optusnet.dl.sourceforge.net/sourceforge/jedit/jedit_4.3pre8_all.deb
sudo dpkg -i jedit_4.3pre8_all.deb
  • Applications -> Programming -> Programmers text editor jedit

How to install Accounting Application (GnuCash)

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install gnucash
  • Applications -> Office -> GnuCash

How to install Personal Accounting Software (Eqonomize!)

sudo apt-get install eqonomize
sudo gedit /usr/share/applications/eqonomize.desktop
  • Add the following to the new file
[Desktop Entry] 
Name=Eqonomize!
Comment=Personal Accounting Software
Exec=eqonomize %i %m -caption "%c"
Terminal=false
Type=Application
MimeType=application/x-eqonomize
Categories=Application;Office;
X-DCOP-ServiceType=Unique
X-DCOP-ServiceName=eqonomize
X-KDE-StartupNotify=true
Comment=Personal finances manager / bookkeeping software
X-Ubuntu-Gettext-Domain=desktop_eqonomize
  • Save the edited file
  • Applications -> Office -> Eqonomize!

How to install Desktop Publishing Application (Scribus)

sudo apt-get install scribus
  • Applications -> Office -> Scribus

How to install Diagram Editor (Dia)

sudo apt-get install dia-gnome
  • Applications -> Graphics -> Dia

How to install Compiled HTML Help (CHM) Viewer (xCHM)

sudo apt-get install xchm
  • Applications -> Graphics -> xCHM

How to install CD/DVD Burning Application (GnomeBaker)

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install gnomebaker
  • Applications -> Sound & Video -> GnomeBaker

How to install CD/DVD Burning Application (K3b)

sudo apt-get install k3b libk3b2-mp3
  • Applications -> Sound & Video -> K3b

How to install Dialup PPP Client (GNOME PPP)

sudo apt-get install gnome-ppp
  • Applications -> Internet -> GNOME PPP

How to install Broadband ADSL/PPPoE Client (RP-PPPoE)

wget -c http://easylinux.info/uploads/rp-pppoe-3.6.tar.gz
sudo tar zxvf rp-pppoe-3.6.tar.gz -C /opt/
sudo chown -R root:root /opt/rp-pppoe-3.6/
gksudo gedit /usr/share/applications/RP-PPPoE.desktop
  • Insert the following lines into the new file
[Desktop Entry]
Name=RP-PPPoE
Comment=RP-PPPoE
Exec=gksudo /opt/rp-pppoe-3.6/go-gui
Icon=pppoeconf.xpm
Terminal=false
Type=Application
Categories=Application;Network;
  • Save the edited file
  • Applications -> Internet -> RP-PPPoE

How to install Boot-Up Manager (BUM)

sudo apt-get install bum
  • System -> Administration -> Boot-Up Manager

How to install Partition Editor (GParted)

sudo apt-get install gparted
  • System -> Administration -> GNOME Partition Editor (GParted)

How to install Firewall (Firestarter)

sudo apt-get install firestarter
  • System -> Administration -> Firestarter

How to install network traffic analyzer (Ethereal)

Note: Ethereal has been abandoned by its developers in favor of Wireshark.
sudo apt-get install ethereal
  • Applications -> Internet -> Ethereal

How to install network traffic analyzer (Wireshark)

sudo apt-get install wireshark
  • Applications -> Internet -> Wireshark

How to install Vulnerability Scanner (Nessus)

sudo apt-get install nessus
sudo apt-get install nessusd
sudo nessus-adduser
sudo ln -fs /etc/init.d/nessusd /etc/rc2.d/S20nessusd
sudo /etc/init.d/nessusd start
gksudo gedit /usr/share/applications/Nessus.desktop
  • Insert the following lines into the new file
[Desktop Entry]
Name=Nessus
Comment=Nessus
Exec=nessus
Icon=/usr/share/pixmaps/nessus.xpm
Terminal=false
Type=Application
Categories=Application;System;
  • Save the edited file
  • Applications -> System Tools -> Nessus

How to install RAR Archiver (rar)

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install rar unrar
  • Applications -> Accessories -> Archive Manager

How to install Extra Fonts

sudo apt-get install xfonts-intl-arabic
sudo apt-get install xfonts-intl-asian
sudo apt-get install xfonts-intl-chinese
sudo apt-get install xfonts-intl-chinese-big
sudo apt-get install xfonts-intl-european
sudo apt-get install xfonts-intl-japanese
sudo apt-get install xfonts-intl-japanese-big
sudo apt-get install xfonts-intl-phonetic
sudo apt-get install gsfonts-x11
sudo apt-get install msttcorefonts
sudo fc-cache -f -v


Note: Ubuntu Dapper comes with the DejaVu fonts (derived from Bitstream Vera) and provides adequate support for Latin, Greek and Cyrillic based languages.

How to install Chinese Input Method (SCIM)

The following advices are outdated and it could be hard to revert to normal afterwards. Please follow instead the official Ubuntu 6.06 Dapper Drake guide HERE

Please note that scim is now installed by default in Dapper, and installing Chinese, Japanese or Korean Support is done using System>Administration>Language Support. The wiki details the method more thoroughly

sudo apt-get install scim
sudo apt-get install scim-chinese
sudo apt-get install scim-config-socket
sudo apt-get install scim-gtk2-immodule
sudo apt-get install scim-tables-zh
wget -c http://easylinux.info/uploads/fireflysung-1.3.0.tar.gz
sudo tar zxvf fireflysung-1.3.0.tar.gz -C /usr/share/fonts/truetype/
sudo chown -R root:root /usr/share/fonts/truetype/fireflysung-1.3.0/ 
sudo fc-cache -f -v
  • System -> Preferences -> SCIM Input Method Setup
  • To activate SCIM
Press 'Ctrl + Space'

How to install Desktop Applets (gDesklets)

Note: Program included in Automatix2. I you have already used Automatix2, this program may have been installed

sudo apt-get install gdesklets
sudo apt-get install gdesklets-data

How to install Basic Compilers (build-essential)

sudo apt-get install build-essential

How to install .rpm to .deb Converter (Alien)

sudo apt-get install alien

How to install Integrated Development Environment (Anjuta)

sudo apt-get install anjuta
  • Applications -> Programming -> Anjuta IDE

How to install C# Integrated Development Environment (MonoDevelop)

sudo apt-get install mono mono-gmcs mono-gac mono-utils monodevelop

How to install Java Integrated Development Environment (Eclipse)

sudo apt-get install eclipse


  • By default Eclipse will use GNU's java instead of Sun's. This will make Eclipse run very slowly and crash from time to time. To solve this problem, we will use Sun's JVM.
  • Install Sun JRE:
sudo apt-get install sun-java5-jre sun-java5-plugin sun-java5-bin sun-java5-fonts


  • Make Sun's JVM default:
sudo update-alternatives --config java
  • Choose the line that says
/usr/lib/jvm/java-1.5.0-sun/jre/bin/java.
  • Edit the JVM Configuration file:
gksudo gedit /etc/jvm
# This file defines the default system JVM search order. Each
# JVM should list their JAVA_HOME compatible directory in this file.
# The default system JVM is the first one available from top to
# bottom.

/usr/lib/jvm/java-1.5.0-sun
/usr/lib/jvm/java-gcj
/usr/lib/jvm/ia32-java-1.5.0-sun
/usr


  • Next, we need to tell Eclipse to use this JVM as well. This can be done on systemlevel or userlevel.
  • System:
gksudo gedit /etc/eclipse/java_home
# This file determines the search order the Eclipse Platform uses to find a
# compatible JAVA_HOME. This setting may be overridden on a per-user basis by
# altering the JAVA_HOME setting in ~/.eclipse/eclipserc.

/usr/lib/jvm/java-1.5.0-sun
/usr/lib/jvm/java-gcj
/usr/lib/kaffe/pthreads
/usr/lib/j2se/1.5
/usr/lib/j2se/1.4
/usr/lib/j2sdk1.5-ibm
/usr/lib/j2sdk1.4-ibm
/usr/lib/j2sdk1.5-sun
/usr/lib/j2sdk1.4-sun
  • User:
gedit ~/.eclipse/eclipserc
JAVA_HOME=/usr/lib/jvm/java-1.5.0-sun/


  • Applications -> Development -> Eclipse

How to install 3D modeling tool (Blender 3d)

sudo apt-get install blender
  • Applications -> Graphics -> Blender 3D modeller

How to install game Tuxracer

sudo apt-get install planetpenguin-racer planetpenguin-racer-data planetpenguin-racer-extras
  • Applications -> Games -> planetpenguin-racer

How to install game Frozen-Bubble

sudo apt-get install frozen-bubble
  • Applications -> Games -> Frozen-Bubble

How to install game Scorched3D

sudo apt-get install scorched3d
gksudo gedit /usr/share/applications/scorched3d.desktop
  • Insert the following lines into the new file
[Desktop Entry]
Name=Scorched 3D
Comment=A 3D Remake Of Scorched Earth
Exec=scorched3d
Icon=
Terminal=false
Type=Application
Categories=Application;Game;ArcadeGame;
  • Save the edited file
  • Applications -> Games -> Scorched 3D

How to install real-time-strategy game (globulation 2 alpha21)

wget http://globulation2.org/releases/0.8.21/glob2_alpha21_i386.deb
sudo dpkg -i glob2_alpha21_i386.deb

you might also need to install dependencies if dpkg returns a dependency error

sudo apt-get -f install

to play use command

glob2

How to install virtual planetarium (Stellarium)

sudo apt-get install stellarium
  • Applications -> Other -> Stellarium

How to install Google Toolbar for Firefox

The current version of Google Toolbar works fine with Firefox 1.5.0.7 in Ubuntu 6.06

In Firefox, click the link below

http://www.google.com/tools/firefox/toolbar/

then click on the big download button.

The official Google version doesn't work with Firefox 2.0 on Ubuntu Edgy for now, but there's a rebuild which works - Google Toolbar Edgy (download this file and open in Firefox 2.0), you can read more information about it on UbuntuForums.org thread Warning! This is unsigned extension, use it at your own risk.

How to install Google Earth

wget -c http://dl.google.com/earth/GE4/GoogleEarthLinux.bin
sudo sh GoogleEarthLinux.bin
  • Leave /usr/local/google-earth as the installation path
  • After installation click Exit. If you instead chose to run the application, read the Note below.
sudo cp /usr/local/google-earth/googleearth.desktop /usr/share/applications/
  • Applications -> Internet -> Google Earth
  • Note: If you run Google Earth for the first time from the installer, it will require root privileges to run the next time. To fix that:
sudo chmod 777 -R ~/.googleearth

How to install KDE Edutainment applications

sudo apt-get install kdeedu
  • Applications -> Education -> ...

How to install Internet Explorer + Flash 9 (IEs4Linux)

This will install a wine'd version of Internet Explorer 6 with Flash 9, as well as IE 5.5/5.01 if you really want them.

  • Note: This installed Flash 9 will NOT be available in browsers other than IE.
  • Install Cabextract. Open a terminal and run
sudo apt-get install cabextract
  • Open a terminal and run this:
wget http://www.tatanka.com.br/ies4linux/downloads/ies4linux-latest.tar.gz
tar zxvf ies4linux-latest.tar.gz
cd ies4linux-*
./ies4linux

Do not run this as root (no sudo), as this can cause the script to malfunction and ruin your X configuration.

How to install Python Development Tools

Python Dev Tools

sudo apt-get install gcc libc6-dev python-dev python-setuptools python2.4-profiler

Install EZ Setup (tool for installing Python stuff)

wget http://peak.telecommunity.com/dist/ez_setup.py
sudo python ez_setup.py

Upgrade Setup Tools

sudo easy_install -U --script-dir /usr/local/bin setuptools

Install TurboGears Framework (optional)

sudo easy_install --script-dir /usr/local/bin TurboGears

How to install Windows Applications in Linux (Wine)

Wine Is Not an Emulator. Wine is an Open Source implementation of the Windows API on top of X and Unix. Think of Wine as a compatibility layer for running Windows programs. Wine does not require Microsoft Windows, as it is a completely free alternative implementation of the Windows API consisting of 100% non-Microsoft code, however Wine can optionally use native Windows DLLs if they are available.

In other words, Wine will let you run Windows applications in Linux.

  • First, add repository for Wine:
gksudo gedit /etc/apt/sources.list
  • Add the following lines at the end of this file
# Repository for wine
deb http://wine.budgetdedicated.com/apt dapper main
deb-src http://wine.budgetdedicated.com/apt dapper main
  • Save the edited file
sudo apt-get update
sudo apt-get install wine

How to install a Drop Down Terminal like in First Person Shooters (tilda)

Do you want a console like in a first person shooter? Tilda should take care of you.

sudo apt-get install tilda
  • The default keybinding is F1. To change the default keybinding, either enter tilda -C at the terminal, or right click on the tilda terminal then click Preferences. While in preferences, you can change other things such as transparency, font, size, and window size.
Personal tools